Cannot fastforward correctly with 'catchup' channel

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Hey guys, I’ve got a weird problem I was hoping you could help me with. When I go to a channel which has ‘catchup’, I select a show and it starts fine. The problem is when I try to skip ahead via the ‘right arrow key’. When I press the ‘right arrow key’ once, expecting the show to jump forward ~10secs (or whatever amount of time you’ve selected, auto 10s 30s 1min etc), the time on the bar at the bottom will jump to the correct time, BUT the video/audio feed will just reset to where it was the moment I pressed the ‘right arrow key’.

    I will press it a 2nd and 3rd time, and by now the bar at the bottom has skipped ahead about 30secs, but my video+audio keeps reseting to where it was when i press the right arrow key. Not until I press the right arrow key for a 4th or 5th time will the video+audio feed jump to the actually time which matches with what is shown on the timebar (so when it finally works, the video+audio jumps to about the 50 second mark).

    When I try to watch a recorded show, or VOD, everything works perfectly. I don’t see the issues I’ve described above. The issues only occur while watching catchup. I tried multiple catchup channels, I did a factory reset, reboots, and none of this helped fix the issue.

    Anyone else see this, or tips on how to correct this? If the developers need a video of this in action to better understand my issue, let me know. thanks

  • Hi,

    I can confirm this issue to, the reason i have not mentioned it as of yet is, i find the problem happens when the total time is not displaying correct, for example if i play a film on tv catchup it may show ie. 1 hour 45 minutes and fast forward works fine, on another film it will show crazy like 140 hours etc and it will do exactly as you describe, i'm not sure if it's provider issue or the app, both my providers are doing upgrades etc and taking way longer than expected so until that's sorted i didn't want to post about it incase it was an issue with provider.

    But yes i'm having same issue with my Z7+ but can't be sure if it's provider or app at the moment as both providers doing major upgrades. The reason i think it's provider at the moment is i only find the issue to happen on anything with a total time that is obviously wrong usually claiming film/programme whatever you watching is several hours to over 100 hours long when it's obviously not. Will try and test a bit more when i got some time.

  • thanks for your input DroidBug. It's funny you mention that, because I first noticed it on a show which is about 90mins long, but the bar at the bottom was showing ~24hours. I first posted this issue in my IPTV provider forum but didnt get much help, so I came here. And as you said, I'm not sure if it's IPTV provider or Formuler box which is the source of the problem.

    I'll keep troubleshooting and if i figure anything out I'll let you know. I'd appreciate if you did the same.thanks

  • ok great thanks for letting me know, at least we both know the issues appears to be when the total time is wrong, both my providers are doing major upgrades and have been doing so for a few weeks and more to follow, the fact it seems to work when total time is correct tells me it's an issue with provider(s) as when total time shows an odd total time that's obviously incorrect, that's when the issue you describe happens, if it was the app it would likely happen even when total time is correct.

    My box is always in use generally throughout the day so can only ever really test at night, but i will take a look at it tonight to see if i can spot anything, as not really tested this issue due to major upgrades going on with both providers is making it difficult to determine the exact cause at the moment.

  • hey @DroidBug (and others), so i was only able to do some testing for ~5mins this morning but I'm seeing the issue on every catchup channel I choose, regardless of whether the total time of the 'catchup' show is correct or not. My next step is to load in another ITPV provider into another portal within MYTVONLINE to see if that's the.

    Note: i accidentally started this thread in the Z+ section and not the Z7+ section as intended...if @SAM you're able to move it to the proper location that would be great. Thanks

  • hey guys, so I've tested two different IPTV providers on MYTVONLINE and I'm able to replicate the issue on both portals. So to recap, i go to watch a catchup channel but the 'advance by 10sec' feature is not working properly. I took a short video which explains the issue:

    (note that it appears that the first click worked properly, but all other clicks showed the bug which I believe exists. Most of the time even the first 'click' will result in a reset to the beginning).

    Let me know if you have any questions, I'd appreciate some of the admins/developers having a look at this if possible, kind of an annoying bug.


  • As was previously mentioned, this could be a server side issue or a MOL issue or a combination of both.

    Anecdotally speaking, I have only been able to reproduce this issue on certain xtreamcodes-flavor Stalker services.
    No issues with catchup fastforwarding on 'vanilla' stalker server.

    It could be a difference in server-side stream-type/encoding or maybe the catchup segment indexes got scrambled on some xtcodes servers during the recent update.

    Formuler is investigating the issue.
    It has been reported to the engineers.

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • ok just an update, i had the issue last night and today where fast forward was fine throughout most of a catchup program that was showing correct total time but on a few occasions it sometimes did not work as seanns32 has mentioned, happened with both providers with different channels etc. i do suspect at this point a bug in MOL. But it's already been reported so that's good :)

  • SAM

    Closed the thread.