No Signal Problem

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • I received my formuler z7+ today was pretty excited. Went through the whole set up process and even got the new beta update and installed fine. After a few minutes of watching IPTV it started flickering and then the no signal came on. After that it never came back on. I did the tutorial on clicking the resolution and went through process about 20 times with no luck. I switched HDMIs and even reset my TV settings. Anyone else with this problem?||

  • Could you describe your Hdmi installation and settings you done before this happen?

    Do you have maybe some other HDMI 2.0 Cable (the cable with Z7+ is only 1.4) for install and test?

  • I pretty much just installed this with the HDMI it came with and it turned on and I did the whole set up and everything worked. I put in the Vaders portal and started watching some channels and then it started flickering and that’s it I couldn’t get signal anymore. I switched it to an HDMI 2.0 cable I have and same thing No video input. I have it connected on HDMI 1 on an OLED LG B7

  • So I formatted my USB to Fat32 and downloaded the zip file to it and I plugged it in. I turned the box on and started clicking CHup and all I kept getting was a red light the green light blinks 3 times and it does this over and over. I never got signal to my TV am I doing something wrong?

  • This instruction didn`t work?


    Quote

    Your Formuler device might be set to an incompatible HDMI output mode.


    Try the following to solve the no picture issue on your TV.Turn ON the TV

    • Pull the power from your Formuler device.
    • Plug power back into the Formuler device.
    • Do you see the Formuler booting logo?
    • Wait at least 2 minutes for the box to boot up.
    • Press the Resolution button on your Formuler remote
    • Wait 5 seconds.
    • Does the picture appear on the TV screen?
    • If not, Press the Resolution button twice
    • Wait 5 seconds
    • Does the picture appear on the TV screen?
    • If not, Press the Resolution button THREE times
    • etc.

    If the above steps don't work, you will need to do a factory reset on your Formuler box.

  • So I formatted my USB to Fat32 and downloaded the zip file to it and I plugged it in. I turned the box on and started clicking CHup and all I kept getting was a red light the green light blinks 3 times and it does this over and over. I never got signal to my TV am I doing something wrong?

    You've done practically all you can do with you z7+. With your new hdmi cable, try using it in another HDMI port of your TV (if you have one). I've seen this help bring a z7+ back to life.


    If still nothing here is a way to see if the z7+ is actually alive. These instructions will require you to have an android device available.


    1) install Air Sync Remote-Z from Google Play Store (a must have anyways - it's awesome)

    2) make sure your z7+ is hardwired to your network (Ethernet to your router [no wifi])

    3) make sure your android device with Air Sync is on the same network

    4) pull power from the z7+, wait 5 seconds, put power back in z7+

    5) Wait for z7+ to show a GREEN light (fully booted)

    6) open Air Sync and at the top will be a device selection box. Tap it and choose the device that appears - usually Living Room 1_XXXX

    7) tap on Mirror Controller icon

    8) if you have a display on your Air Sync device move to next step

    9) on the remote press the RESOLUTION button every 1 second until 720p60 is highlighted

    10) wait 5 seconds - is there now a display on the TV? If not, continue...

    11) RMA your z7+. It would appear the HDMI controller is defective or the port itself isn't properly soldered.


    Best of luck and I hope my instructions helped. The z7+ is a great piece of hardware!!

  • I just experienced this same issue. And tried everything above excluding the Air sync since I do not have any other Android device. What now? Thanks in advance!