MyTVOnline unusable

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Hi,

    I was having issues with my Z Prime box as it would not install any apps or update MyTVOnline. It always failed with a 'parse error' so I performed a factory reset.

    I can now install other apps from the market but I am unable to use/update MyTVOnline app.

    When I select it from the menu, it asks if I want to update, I select yes and the download progress bar flashes up and then disappears.

    This happens every time I try to launch app from menu.

    I have also tried from the market but it also results in similar experience, download appears to start, then stops.

    Can anyone help? How can I use the MyTVOnline app if it can't install/update? :(



  • Hello,

    Please do a factory reset and update your device from the Update app:

    Home > Settings > Update

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • Hello,

    Thanks for the reply.

    I don't see any 'update app' in the settings screen?!

    I have 8 options in a 4x2 grid:

    • Language
    • Wi-fi
    • Ethernet
    • Display area
    • Date and time
    • Parental
    • System
    • Android

    Is there a hidden settings screen that I'm not seeing? Or am I looking at the wrong thing?



  • I tried looking in the 'System' menu also but don't see anything there related to update either...

    Only system info and options to set startup app, factory reset & software reset.

    Hope you can help, sorry new to the formuler family 🙂

    Thank you,


  • Hello,

    I don't think my formuler z prime is recieving firmware update. Probably why I can't see update app.

    When I switch off, reboot, it checks for updates and the progress bar appears for a second then disappears...

    Current system details are:

    S/W Version: v2.7.82

    S/W Revision: r11734

    Build date: 08-11-2017

    I see there was a new build, April 2018, v2.8.13 which includes the update app you mention.

    Is there a way to manually update the firmware?

    Thanks again


  • Hello,

    Thanks for waiting.

    The engineers found an issue in the upgrade service backend.

    Please use the following method to update to the latest software:

    Go to the Market

    Download and Install the SW Update app

    Open the SW Update app from the same screen

    Install the available updates and wait for the set to reboot

    Go to Home > Settings > Update to receive the latest official software.

    Please note if the set is locked down and a 3rd party market is installed, the set needs to be unlocked or factory reset in order to see and download the SW Update app from the Market.

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • Hi,

    Thanks for the update and advice.

    Will give this a try tonight when I get back home and let you know how it goes...

    Thanks again,


  • Hi,

    Sorry for the late reply, been away for a few days...

    I tried out the steps above and managed to update the firmware & MyTVOnline app successfully!

    Thanks for all the help, very much appreciated 👍🏻



  • SAM

    Added the Label Solved
  • SAM

    Closed the thread.