Formuler z7+ keeps getting stuck in boot

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Hi

    With thw last couple of weeks my device keeps getting stuck in boot i have done a factory reset with usb each to solve the issue any know why this keeps happening i also changed the power lead thinking that might be the issue but no

  • Can you give some more details about which screen it gets stuck at?

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • It trys to load its goes as as far as the purple screen where it says please wait for about 5 seconds and then its like the box powers off and my tv displays no sorce in hdmi.

    So it displays 3 screens on loading the first grey screen with the formuler logo then the big circle and the purple screen with please wait and small loading circle for 5 seconds and then just powers off would it be a hdmi issue?

  • From what you have described, the device is booting into Android which is a good sign.

    It seems like you have set MYTVOnline as the startup app.


    Do you see the "Connecting to... PORTAL" screen?

    When the screen goes black, is the status light on the front of the unit still green?

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • No dont think i have myTVonline setup as a start up on boot app that means when it fully loads it will load myTVonline automatically?


    No dont get connecting to portal screen.

    Not sure about the light dont think it stays green its like it goes to deep standby mode

  • No dont think i have myTVonline setup as a start up on boot app that means when it fully loads it will load myTVonline automatically?


    No dont get connecting to portal screen.

    Not sure about the light dont think it stays green its like it goes to deep standby mode

    Video would be helpful.


    Does the device boot to the home screen before the screen goes black?


    After the screen goes black, what happens when you press the power button on the remote?

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • I reset it again this morning with usb no it dosnt go as far as the home screen it trys to load and then goes back to the tv screen as if there was no device connected to the tv