z7+ red light of death

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Different to the stuck in stand-by issue in that unplugging and plugging doesn’t resolve.


    Since yesterday whenever I plug in the z7+ I get a red light for a second, then green for a second then continuous red. The light stays red and box doesn’t boot up at all, doesnt respond to the remote.


    I’ve been recommended to try the factory reset tool, so have downloaded and will try that tonight.


    Is there anything else I can do? Anyone with any experience of this issue?


    Thanks!

  • Have you tried disconnecting everything but HDMI and power from the box? I don't know what setting I had on my router that it wouldn't allow my box to boot, just stuck in a loop, by chance I disconnected the LAN and WIFI and the box booted up and from there I figured out what settings I had wrong.

  • Thanks FR & BL.


    I tried the factory reset usb tool it just ended up displaying the z7+ formuler logo and stuck on that.


    I've never used the wifi but will try disconnecting the LAN tonight, hopefully that helps otherwise will have to be sent back.


    Heard elsewhere someone has similar issue and unplugged/plugged 35 times when it suddenly started working, not sure I got the patience for that lol.