EPG Time zone issue

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • So I've recently noticed an issue with the EPG and the listing of shows in the guide. First off I'm in the US Eastern Time Zone which is currently UTC -5 because of daylight saving time. The EPG Mode is UTC and the Manual EPG Offset is 0 and the shows currently show up correct, meaning the Info is for the correct show at that time. For instance the current time here is 6:15pm and the EPG is correct, the issue is the block of time from 5pm-6pm shows No Information, the info from earlier than 5pm shows correct info and is highlighted red so catchup is available. In order for the show info to show up for 5pm-6pm I believe the actual time has to go past 7pm then the show info for 5pm-6pm seems to show up and catchup should be available at that time.


    I've messed around with changing the UTC to Normal and changing the Offset however to get the show info correct I have to set it to +5, the show names and info seem to show up this way but they don't show red for catchup. I have to wait till the current show or until the next hour, 7pm in this case, for catchup to become available for the 5-6pm show.


    I have checked the catchup\Archive in Perfect Player and the last show seems to be available for the episodes that I checked, meaning I am currently able to watch the episode that aired at 5-6pm from PP when it shows it's not available in MyTV.


    I'm going to validate this after 7pm and see if everything from 5-6pm shows up and catchup is available. Currently I left it to Normal and +5 Offset.

  • So currently it is 7:05pm, hour long episodes from 5-6pm are now available for catchup, but the hour long show that started at 6pm is not available for catchup. So it seems like it takes an extra hour for things to become available for catchup. An odd thing is with half hour shows, a show that started at 6:30pm is available via catchup but the one starting at 6pm is not even though it's now 7:10pm.


    Also I don't normally record things through the z7+, but I recently tried to record 2 things, one overnight and another just an hour ahead from when I was watching it but neither worked and I do have a MicroSD card in and am able to use timeshift. So I would think it should record, not sure if its related to any of these time issues.


    Weird.

    Edited once, last by rjm_27 ().

  • Regarding the recording: there's a lot at play here. The common issue is that there is a temporary issue with the actual stream and this causes the recording to stop prematurely.


    Does your recording work at all? i.e. while you watch TV, lress record and record for 10mins while you're watching. Does it record and can you watch the recorded file successfully?

  • First off, sorry about the length of this but figured it might help someone else out there or could lead to getting a bug fixed.


    I ended up reformatting the MicroSD card to NTFS (originally it was exFAT) and reinserted it into the z7+ and rebooted the box. It created an Android dir along with a LOST.DIR and System Volume Information dir. I went into MYTV and set up a recording and I got the warning on the screen to switch the channel and I did and when it did that I got a big Warning box saying Can't Record this stream. I tried it a couple more times on a couple different channels and now it started working.


    I tried to set up a recording and shutdown the box and see if it worked and that seemed to uncover a whole other issue! It didn't do anything at the time when it was supposed to start recording, but after a min or so it started recycling the box every min or two. It boots into the Z7+ boot up screen, then the circles, then goes to Preparing to Start and then it shuts down and in a min or two it does it again and looped for a few times then appeared to stop. I manually turned it on and it came up and I went into MYTV and it started recording from the time I went into MYTV, not when the show started.


    After more testing I might have stumbled on something. I was setting up the recording to start within a couple min and then shutting down the box, I did this a couple times and it went into the reboot loop. I set another one up that started in about 10 min and shutdown the box. 5 min before the recording was supposed to start the box woke up and the recording started at the scheduled time. I tried it a couple times and it started recording the program as it should.


    So recording seems to be working now since I reformatted it. Previously it was writing the timeshift file on the MicroSD card so it was accessible just don't know why the recordings weren't working, but they seem to be now.