Z8 ethernet connection issue

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Recently upgraded from the Z7+ to the Z8 but not having the best experience so far. If the ethernet is connected it fails to load at times getting Error code 7, if I unplug and do it through WIFI it loads up but Tv viewing is not streamless with it freezing every 20 min or so and then I have to change channels and go back or turn on/off ect to get viewing again. I found with my Z7 having the ethernet connected resulted in near perfect viewing with any issues happening in days rather than minutes. Ive tried loading the Z8 box up through wifi then adding the ethernet but it is just not reconising it using with a small exclaimation mark appering in the network icon, I was wondering if my sky router was blocking signals to the z8 andriod box as I know the BT router you have to turn off certain settings but ive not found any help as of yet any help advice would be gratful many thanks

  • Just installed it and tried several times doing all the usual stuff but no joy, it does pick up ethernet and says connected and shows IP address but when I click on mytv2 it just fails to load. Just rebooted it up through wifi and its working but less than 10 min into watching and screen gone black so have to turn it over and repeat usual crap.

  • I was wondering if my sky router was blocking signals to the z8 andriod box as I know the BT router you have to turn off certain settings but ive not found any help as of yet any help advice would be gratful many thanks

    I read the sky router is big source of problems in UK.

    Do you use also IPV4 or only IPV6?

    Did you try with VPN, maybe is some ISP blocking in background?

  • Peo587

    Stop to write in German language if thread started in English! You did it already in few other threads too.

    If you want to speak in your language, then open own thread and write all at once inside in German.


    By the way kev8 issue have nothing to do with your problem and this thread belongs to him and his issue.

    Thread hijacking is bad and will not tolerate any more. Read the forum rules. Thanks for understanding.


    last two postings deleted!

  • Just installed it and tried several times doing all the usual stuff but no joy, it does pick up ethernet and says connected and shows IP address but when I click on mytv2 it just fails to load. Just rebooted it up through wifi and its working but less than 10 min into watching and screen gone black so have to turn it over and repeat usual crap.

    *This can be applied too anyone with intermittent / unstable connections or buffering issues using any Internet provider, you just don't have to disable ipv6 as you do with sky for it to work (apart from some EE routers also)


    *Also if anyone already use a decent vpn provider this would not benefit you as it would be creating more lookups than required / necessary as your vpn provider will have their own dns servers which in effect can conflict and also leak outside of your vpn


    Hi Kev, try the following. The whole process will disable Sky Broadband Shield(which blocks certain content delivery and also causes buffering as its constantly monitoring your internet traffic) and also disable ipv6 in your sky router and then manually configure your wifi connection on the z8 box to use an open public dns service, see which one works best for you, I always find cloudflare dns servers to work best so I'll include their addresses in the configuration, you have too disable ipv6 on sky routers to be able to configure your own dns addresses from the device, if you don't disable ipv6 sky will always over ride any manually configured device with their own servers as most of their features and services depend on it to work i.e Sky Broadband Shield.


    A few people at this point maybe asking where does dns play a part in streaming or a stable connection. Most major Internet providers don't tend to have their own local dns servers, they tend to use third party dns services which for most Internet providers in my experience are bottle knecked an over capacity hence not being very fast at translating addresses.

    Cdn's(Content Delivery Networks) use various methods for geo-targeting, using a Users dns is a pooular one. At the dns stage cdn's don't see the users ip address, it only see's the dns making queries. More often than not cdn's will make an assumption that the dns server is somewhere near the end user, which in effect if they are not near can result in poor content delivery, buffering, unstable or intermittent service but in the same breath an open public dns service may also connect you to a dns server that is nowhere near you, they just do a better job in general, for example Cloudflare is more private, secure and fast so if a content provider has many servers around the world their dns will will provide the ip address within close proximity of the dns resolver resulting in less bandwidth consumption, quicker delivery speeds, more stable and less buffering.


    Firstly Kev, check that Sky broadband shield is turned off, to do this login to your sky account with your sky ID on the sky website, once logged in goto my details/account, then select Broadband & Talk, then scroll down the page an select Broadband Shield. It will either have an option to switch it off if its already on or an option to switch it on if its already off. It needs to be completely switched off.


    Once that's done open a Web browser on any device connected to your wifi, in the address bar type in 192.168.0.1 press go/enter, that will take you to your sky hub management page.


    At the top select "advanced", it will then ask for a user name & password.


    User name: admin

    Password: sky


    Login, then under advanced settings in the next sub category select "Lan Ip Setup". Now scroll down to "Lan Tpc/Ipv6 setup" There will be 3 tick boxes selected.


    Enable IPv6 on LAN side

    Enable ULA Router Prefix

    Enable IPv6 DHCP Server


    Untick them in the reverse order, so start from the bottom an work your way up, Untick them in this order


    Enable IPv6 DHCP Server

    Enable ULA Router Prefix

    Enable IPv6 on LAN side


    Then scroll to the bottom of the page an click apply to save changes, make sure you click apply at the bottom an not the one above. This will then restart your router for the changes to take effect, confirm and restart.


    Once your router is all back up an running to its normal state goto the settings menu on your z8, select network, then select your network your are connected too, make a note of your ip address that's displayed, then scroll down too Ip settings, select static, input your ip address if it hasn't already default it in, press enter to proceed an it will ask for your gateway, in your case will be 192.168.0.1 (for anyone else your gateway will be the same as the ip address used too mange your router i.e BT & Plusnet - 192.168.1.254 Virgin, Sky, Now TV - 192.168.0.1 EE & Talktalk - 192.168.1.1) then press enter to proceed, it will ask you for a network prefix length, type in 24 and press enter, this is where you configure your dns server addresses, so using cloudflare, dns 1 is 1.1.1.1 then press enter, dns 2 is 1.0.0.1 then press enter too connect an job done, you've already give your router a restart, just give your box a restart for a refresh.

    👌

  • Many thanks Codeit for taking the time to share this info, I have turned my shield off already so I know its not that, that was the problem I was having with Z7 box and then it worked a treat. You have given me some good stuff to work through there so thank you, I am still having issues with screen freezing and no ethernet pick up even though im getting 867 mbps at the time of writting this so I will work through what you have shared and report back, many thanks again in advance.

  • SAM

    Added the Label Guidance
  • I have had great success todate with the help and advice from CodeIT and its much appreciated, and I hope you can help me further. It appears from all my trying that the new Z8 is not a lover of the ethernet connection, which because of the quality pick up of the wifi this is not so much an issue as it was with the Z7+ but interesting to know if there is a way of config the Z8 to see if ethernet is even better. The other main problem im having is that a family member has BT internet and router in there home and the Z8 just comes up code7 error, is it possible and how to duplicate what I did with the sky internet with turning off

    Enable IPv6 on LAN side

    Enable ULA Router Prefix

    Enable IPv6 DHCP Server

    or is there another way to get things working. many thanks.

  • Hi Kev. That will more than likely be the bt smart setup feature in the bt hub, smart setup's purpose is to help/guide you through connecting a device to your router for the first time taking you through a configuration process and attach bt's services and features compatible with that device, although this maybe handy for most, it takes a drain on the functionality of your router an devices so just swith it off an then restart the router.


    Open a Web browser on any device connected to the WiFi, in the Web browser address bar type


    192.168.1.254


    Press enter/go an that will take you to the bt hub managent page.


    If you have a lot of colour purple on the interface of the bt hub you've just logged into then scroll down to the bottom of the page an you will see the smart setup section, select smart setup the the router will request a password, the password is on the bt hub(not the WiFi password) there will be another password on the hub worded similarly to "admin password" "settings password" "hub manager password" type in the password then it will take you into the smart setup section. There will either be 2 circles labelled yes & no, if yes is selected then select no and save thd changes, then reboot the router or there will be an on/off switch, just switch it to off, save the changes and restart the router.


    If you don't have lots of colour purple on the interface of the hub then at the very top of the page menu you will see "advanved" select advanced then go to "home network" on the sub catigory below, then again below on the next sub category select "smart setup* and again either select no or turn of the switch, save the changes and restart the router.



    You could also double check that the parent controls are turned off as that will block certain content and ports. (Obviously taking into account that they are filters to stop children from accessing anything you'd rather them not)


    To check for parental controls goto the bt Web page, log in with your bt ID on that page look for "your package" then "manage your package extras" (something similar to those words) look for bt parental controls an then select parental control management a select your preferred configuration(Ideally off if there are no younger generation).. 👍


    You could also apply the same manually configured network adapter settings as you did with yours only the ip address an gateway will be different. Double check the ip address an the gateway will be 192.168.1.254

    Then dns 1 - 1.1.1.1

    Dns 2 - 1.0.0.1

    Edited once, last by CodeIT ().

  • Soon as I finish work today I will pop round to family members house and follow out these instructions and hopefully like my Z8 box they can enjoy the service I now do. I can not underestimate the gratitude for you taking the time to share this information, I am sure it will help not only me but many members of this forum/community. I think this site would do well to point members in your direction for help and advice if its not to much of a burden on your time/resources ect, the average person would not know where to start with a lot of this stuff. Also you have covered help for the big UK routers in Sky & BT and if your happy to share more with the community can you breakdown the same help for the Talk Talk router please mate. If I could buy you a drink CodeIT I certainly would, have a great day mate.

  • Hi CodeIT’s on this occasion with the BT router and Z8 set up it has not been succesful, everything you said was correct and I followed to the letter and the error code7 no longer appeared but when trying to load up the Mytv2 it just stays at 10%. For some reason between the BT router and the Z8 box the internet is failing, in settings it is acknowledging internet connection and showing nearly 900 mbps to start with but then somthing is shutting it down and the explaination mark is showing, when Ive loaded up on my laptop the BT homepage a browsed through stuff it is registering that the android box is there but also saying no connection. All parental guidence ect is off, smart is off also. There is nothing wrong with the box I bring it home and its straight back on with my Sky router no problems, its surly an issue between BT & the android, mytv2 connection. Hope you can help mate.

  • Hi Kev, did you manually assign the z8 an Ip address using the method I explained?


    If you did hard reset the router if you think it has issues, firstly on the z8 goto settings, network, select your network then select forget network. Once that's done hard rest the router, you can do this by either logging into the router management as explained via a Web browser an navigating through the menus to factory reset or there should be a pin hole or reset button on the back of the router somewhere, if pin hole push a cocktail stick in gently an hold it down for 30 seconds, same method if its a button.


    Once reset, on another device connect it too the wifi/router with the same method an turn of smart setup, then reconfigure the WiFi connection of the z8 using the same method by manually configuring the ip address.


    Once that's done goto the app store (Google play store) search for


    Analiti


    Install it, open it, let it do its thing, take a clear picture of the results. After the speed test on the left hand side goto wifi channels, take a clear picture of that screen. Post both pictures here for me to see. 👍

  • Hi CodeIT you have done it again my friend, I deleted the current network set before leaving my house, and took it back to the new location, before starting I inseted a pin into the BT router and reset, I then connected everything up and re-entered the password for the new address and then my provider for my MyTV2 loaded up instanly and no issues what so ever for the hour I stayed there, fingers crossed that its sorted now. Once gain massive thankyou, your help has been fantastic.