Cannot Get Formular z7+ to turn on. Red light stays constant

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Model: Formuler Z7+


    Retail Box or Provider Box: Retail Box / Provider Box



    Firmware version and date:

    Last updated 2 weeks ago. Unable to get a picture on my screen to confirm

    MYTVOnline version and date:

    As above

    Did you factory reset your device? and when?: yes /no

    Have attempted but cannot get a screen to come on my tv and the light to turn from red to green

    Picture url (only https): (if you have pictures please include the url to the picture(s) or attach small picture.


    Please see attached


    Video download url (only https): (if you have managed to video record you’re issue please provide link to the video)




    What issue(s) are you having? (please provide full details of issue in an easy to understand manner)


    Box was working fine until two weeks ago. I seen that there were problems with one of the updates through the forum group i'm on and when i have tried to watch TV on the box i noticed that mine would not switch on. I dont even get a boot screen when i power down and restart. The red light on the front of the box just stays a constant red.


    I have tried a few different hdmi cables, i have tried with and without my Ethernet connected and as mentioned i have bought a usb hard drive to try and get it to factory reset all without any luck even changed the batteries in the remote too


    What was you expecting to happen? (please tell us what you were expecting to happen)


    For the box to turn on


    What happened instead? (please tell us what happened instead)


    Wont turn on


    How can we replicate the issue you are having? (please provided easy to understand, exact instructions on how we can replicate the issue)


    Not sure


    What have you tried if anything to rectify the issue? (i.e. rebooted device, factory reset, powered off device, replaced cable etc.)


    Think i have described what i have done in the main body of the post




    I thank you in advance for any help given.

  • Thank you for using the form :thumbup:


    Please try following, if you know your firmware on the box is already updated to 1.2.71.



    ----------------------

    Starting from Firmware version 1.2.71, all Z7+ and Zx series devices support the following reset method:


    Built-in Factory Reset: Destructive

    **Factory resetting the device will delete all user data and restore the system back to factory state.



    1. Remove power from the device.

    2. Re-insert power WHILE simultaneously rapidly pressing the red button on the remote

    3. The front status light will start to blink red and green.

    4. Stop pressing the red button

    5. Press 1 on the remote and wait for the reset procedure to complete


    This built-in method is more convenient and does not require the use of the USB file.

    The USB file method also works if needed (if firmware version cannot be determined)

    -----------------------


    The USB file method:

  • Hi thanks for the reply. Neither method is working. I have tried both the usb mode and the new built in mode. The red light comes on instantly when turned on but never goes a different colour and nothing appears on my tv at all

  • Hi Sam or any of the people on here. Any idea what else I can do? I’ve only had this about a year and would expect it to work longer than this


    Thanks

  • Sorry, but no idea if factory reset does n`t work. Please open Support Ticket on Formuler Helpdesk, maybe they have better idea.


    Edit: Btw. just idea, do you have maybe same power supply adapter like on Z7+ to test with this?

  • SAM

    Closed the thread.