Dolby Digital 5.1

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Hello,


    I'm having problems getting Dolby Digital 5.1 working. I saw this thread and followed the instructions however it did not change anything. I've tried all of the HDMI outputs with no success. I also installed the Media Optimizer app today but it didn't help either. Should I try using an optical cable next or am I missing something?

  • If you use AVR Receiver (guess this is what you want) then change HDMI from LPCM to RAW in Android settings, this is audio passtrough.

  • Try optical cable.

    Did you get an message that mytvonline asked for an codec to download?


    If so, download it!

    No, I have not been prompted to download any codecs. I read a post from Sam that indicated that MyTVOnline 2 comes with the required codecs.

  • If you use AVR Receiver (guess this is what you want) then change HDMI from LPCM to RAW in Android settings, this is audio passthrough

    Yes, I am using a Yamaha receiver. I did change the HDMI settings from LPCM to RAW but it did not help. I've also tried different HDMI cables, to no avail.

  • I read a post from Sam that indicated that MyTVOnline 2 comes with the required codecs.

    No because the first time after Box setup and zapping trough 5.1 channels the box says external codec necessary and ask to confirm the codec install.

    Please note, there are only few channels with 5.1, check audio track (red button) to be sure !

    You say Media Optimizer app is installed, i think you mean Audio Optimizer App? If installed, please execute it again and restart the box.

  • No because the first time after Box setup and zapping trough 5.1 channels the box says external codec necessary and ask to confirm the codec install.

    Please note, there are only few channels with 5.1, check audio track (red button) to be sure !

    You say Media Optimizer app is installed, i think you mean Audio Optimizer App? If installed, please execute it again and restart the box.

    OK, this is good to know. Thank you Sam. I'll do this when I get home and post results.

  • Well I've had some success. I reinstalled the Audio Optimizer, rebooted, found a couple of channels that stream in Dolby Digital 5.1 and it worked. Interestingly enough I was never prompted to install any codecs. I still don't get 5.1 when using Plex, however. When I fired up Plex for the first time it asked me if I wanted to use Passthrough Mode, to which I selected Yes, but it still doesn't work. The current show I'm watching is using Direct Play with EAC3 5.1. Is this supported by the z8?


    I still have a Shield so this isn't a show stopper. Just a minor first world problem to switch between the two devices.

  • Must be an issue with Plex. I get DD 5.1 in MyTVOnline as well as Media Center. Strange. Not a lot of audio settings to play with in Plex. Maybe I'll have to go back to Kodi...

  • Got it all working now. It wasn't clear to me that I needed to install/configure the apps from the Market first and then update them through Google Play. Everything seems to be working now.

  • SAM

    Added the Label Solved