Z7+ 5g box not responding to remote

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • This just stopped working today. I power up the box by reconnecting the power supply, it loads the home screen where I see the MyTVOnline launcher. However the remote no longer is recognized by the box, I can't navigate or click on anything. The Source button lights with each key press. Pretty sure the remote isn't the issue as I've changed the battery, the TV button still turns on/off my TV, and this remote is able to control a second Formuler box I have elsewhere.


    Is there a way to troubleshoot this? Can I perform a factory reset if I can't navigate through the box? Thanks for any help.

  • This just stopped working today. I power up the box by reconnecting the power supply, it loads the home screen where I see the MyTVOnline launcher. However the remote no longer is recognized by the box, I can't navigate or click on anything. The Source button lights with each key press. Pretty sure the remote isn't the issue as I've changed the battery, the TV button still turns on/off my TV, and this remote is able to control a second Formuler box I have elsewhere.


    Is there a way to troubleshoot this? Can I perform a factory reset if I can't navigate through the box? Thanks for any help.

    Does the light on the front of your Formuler device flash when you press a button on the remote?



    Install 'Air Sync Remote Z ' from the Google Play Store on your Android mobile phone.

    Connect your mobile phone to the same local network of your Formuler.

    You can use Air Sync's virtual Remote control feature to perform a factory reset to see if it solves your issue.

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • Problem solved by unplugging the remote control extender. The box works fine and even with the extender plugged in again.


    Sincere thanks for all comments and suggestions.

  • SAM

    Added the Label Solved
  • SAM

    Closed the thread.