WiFi Randomly Disconnecting and giving "!" on current network

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Try this as last option. Change in Router DNS Server from current ISP to Google DNS Server. You can also use Cloudflare DNS Server which is much better.


    Google DNS Server v4:

    1. 8.8.8.8

    2. 8.8.4.4


    Cloudflare DNS Server v4:

    1. 1.1.1.1

    2. 1.0.0.1


    Cloudflare DNS Server v6:

    1. 2606:4700:4700::1111

    2. 2606:4700:4700::1001

  • Greetings SAM, I actually tried that earlier this morning! I attempted to set up as Static IP, used the Cloudflare DNS Server v4 + it was working wonders again. However after about 8 hours my TV stopped streaming + I received that damn little "!" over the WiFi lol

  • SAM  175n after some extensive testing I believe I have resolved this issue. Wanted to pass it along so you guys know, as well as a potential fix for other people. So what I had to do was


    1. Logged into my Router.

    2. Went into the "Wireless 5GHz" tab.

    3. Turned off/Unchecked "WMM Power Save Mode"

    4. Chose "Apply"

    3. Then went + clicked on "Advanced" settings.

    4. Under "Wireless Mode" it was originally set to "A/N mixed" ..

    5. After switching Wireless Mode to only "N" + apply/saving settings, I have now been connected to the 5GHz WiFi for about a week now + have not received the "!" once.

    *knocks on wood*


    Thanks again for all the previous help!

  • Change in Router DNS Server from current ISP to Google DNS Server. You can also use Cloudflare DNS Server which is much better.

    Adding to that, generally speaking, when using a VPN provider it is recommended to use the VPN provider DNS.

    Using the VPN provider DNS will avoid unnecessary leaking DNS data to a 3rd party.

  • im have the same problems with the box not connecting with WiFi or ethernet wish I’d never bought it

    Wi-Fi connection issues can be caused by "interference", see for example: expertreviews.co.uk article


    For ethernet: Do the ethernet leds blink on the ethernet connector at back of the box? If yes, which colors are lit or blink? (to make sure there is actually a link active)


    Next other stuff can be checked, are you using DHCP or Static IP?

    If DHCP, does the box get an IP? Both IPv4 and IPv6?

    If static, are you 100% sure the IP is not already in use and routable and not blocked by a firewall setting in the router?

    have not received the "!" once.

    My Z8 shows the "!" around 50% of the time and always works fine.

    It seems that Android has issues with performing network health tasks when VPN is active.

  • im have the same problems with the box not connecting with WiFi or ethernet wish I’d never bought it

    Which country? Which ISP?

    Are you using ISP-supplied modem/router?

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • I have a WiFi extender sat right next to the z8 box with Ethernet port where I an plug in but no lights to show it’s working

    It’s connected again to WiFi but for how long I don’t know

  • no lights to show it’s working

    I just checked, my Z8 also has no ethernet port lights. So that seems to be normal. I made a wrong assumption that there would be lights.

    Perhaps you can check for lights at the other end of the cable, normally the ports on extender/router/cable-dsl-fiber modem do have these link and connectivity leds. One green and one orange.

  • My Z8 shows the "!" around 50% of the time and always works fine.

    It seems that Android has issues with performing network health tasks when VPN is active.

    I appreciate your response as well! But yeah, it had nothing to do with my VPN. I was getting the "!" point even when not connected to VPN + unlike your issue, once I received the "!" point the internet connection would cease + I would have to restart the box in order to load or play anything. Unfortunately it never worked when I got the "!"..

  • I would have to restart the box in order to load or play anything.

    After rebooting it always works? (and then it remains working for a short period?) (does it stop working when the Z8 is idle or does it stop also in the middle of an active network audio/video stream?)


    Is it possible to test with connecting the Z8 directly to the internet router/modem from your internet provider? If the connection remains active then there must be some DHCP/Routing/IP/Firewall/UPnP issue with the device it is normally plugged in to?


    Alternatively: I have disabled UPnP, it should not make a difference, but perhaps it also helps in your setup.

  • Yeah, after rebooting it would always reconnect to Wi-Fi. However, sometimes it would be 5 minutes after reboot then I would receive the "!" + other times I could go almost the whole day before the "!" popped up + had to reboot. Usually something was playing on the Z8 (MOTV2, Youtube, Plex) + it would just stop/freeze mid show/video, going back to the home screen I would see the "!" + if I tried to load any type of app that used the network, I would get "no internet connection" or nothing would search for me until I rebooted. There was a small # of times that the box would be on when we went to bed with nothing playing, then in the morning when we got up the box would still be on, + the Wi-Fi would now have the "!".

    I never did test directly with the ethernet. The cord I had ended up being bad + never went to purchase another. I do have UPnP disabled, but did not appear to help either! I was changing the DNS to both Cloudflare + my VPN provider but that did not seem to help either. It wasnt until I started playing around with all the settings in my Router settings that I stumbled upon "Wireless Mode" .. Since it has been set to mode "N" it has been going strong for almost 2 weeks now .. being the Wireless Mode was originally set to "A/N mixed" .. my conclusion is there must be something either in the "mode A" that doesnt work well with the Android OS or something with Android OS that doesnt like Mode A lol

  • ...my conclusion is there must be something either in the "mode A" that doesnt work well with the Android OS or something with Android OS that doesnt like Mode A...

    That sounds more like the interference described in the article I referred Matthew to, earlier today:

    Wi-Fi connection issues can be caused by "interference", see for example: expertreviews.co.uk article

    Either way, if it is fixed, don't bother. ;)

  • one last little tidbit for anyone wondering or that may come across this issue ... according to the product details, wireless specs that I was able to find for the Z8: Wi-Fi Dual Band with Antenna: 2.4GHz & 5GHz 802.11ab/g/n/ac .. so it appears my original wireless setup with Wireless Mode of "A/N mixed" is not supported on the Z8 because the Z8 does not support Wireless Mode "a" .. so every time it was switching to "a" must've been why it was disconnected + not reconnecting until I rebooted + it reconnected to the Wi-Fi on "n" mode


    Matthew I am glad you were at least able to get Wi-Fi connected. :) Perhaps if you have another Ethernet cable, see if it stops working again, just a thought!

  • This worked for me as I was having the exact same issue! Although one question, when I change to "Mix of AC and N" it goes right back to the same problem. If I leave it on "only N" it seems to be flawless (just played around with this for a bit last night). I'd like to take advantage of the "AC" though if I could and as you pointed out out, the Z8 does accept "AC".


    Both SSID's are named diff. D-Link 819 router. Any thoughts? Thx in advance.