MyTVOnline not connecting to Portal

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

    • Model: Z7+
    • Retail Box or Provider Box:
    • Firmware version: 1.2.98
    • MYTVOnline 1 / MYTVOnline 2 version: 1.9.398
    • Connection with provider: MAC registration
    • Box connected with: Ethernet
    • Did you factory reset your device? and when?: Yes, 2 times. Today one, other 1 week ago
    • Picture url (only https):
    • Video download url (only https):
    • What issue(s) are you having? See text below.
    • What was you expecting to happen? That I could watch TV channels again.
    • What happened instead? Issue is still there.
    • How can we reproduce the issue you are having? Impossible.
    • What have you tried if anything to rectify the issue? See text below.



    The IPTV host guy activated my Formuler Z7+ last year June. Since the end of April and begin May, the channels are not working anymore. I always tell the IPTV guys that I have a MAC Android box, and that they can activate MAC address. After an recent update (around april) it got messed up. I end up with the error: Check your internet connection, your account is blocked or expired. Contact your service provider, whenever I try to connect to the portal. My account is not blocked. I just downloaded StbEmu on my Android simulator. I set up MAC ADDRESS (of MyTVOnline) + IPTV link of my provider, and somehow it works on the StbEmu app. I think that something is wrong with MyTVOnline.


    My mum has the same device, different provider, but same technique is been used. It's annoying that I do not know what to do next. Am I the only one with this experience?

    Things I tried: different providers, different portal links, factory reset.. Nothing worked.

    Edited once, last by Blackadder: Added template ().

  • Hello,


    You say factory reset and fresh install was made and not even other providers work? This looks like ISP blocking and would explain the error message.

    Did you tested to connect your box with phone tethering/hot spot and bypass your ISP? Did you tested with VPN, it could be that your ISP started to block streaming?

  • Did you tested to connect your box with phone tethering/hot spot and bypass your ISP?

    Hello,


    Thx for responding.


    I just did. I still get the same error message.

    I live in the Netherlands. Meaning that internet will not be blocked.

  • Hello,


    Thx for responding.


    I just did. I still get the same error message.

    What ID did you give the “IP TV Host guy”? Did you give them the ID displayed in the top right corner of the screen (ID), or the MAC address (displayed in the bottom right corner of the screen? The one you should use, is at the top.


    I live in the Netherlands. Meaning that internet will not be blocked.

    I wouldn’t state it quite so boldly… I live in the Netherlands as well, so I know that the very strict Dutch net neutrality legislation has changed at the hands of the EU. Though chances are really slim indeed, the likelihood of internet services being blocked has increased since the EU dropped its version of net neutrality down to our government. Much of the Dutch legislation is, fortunately, still intact, but a blocking order can now be passed by a judge. Think about a certain site that would allow a certain way of sharing that is no longer legally accessible from the Netherlands (sorry for the cryptic mess; I just don’t want to be accused of mentioning stuff I shouldn’t because of site conditions). You know the one… Prior to 2016, things like this were unheard of. Since then, though...

    I will give you this: the aforementioned site is, to this day, the only one that is actively being blocked by Dutch ISPs. No other site, service or protocol has received similar treatment.

  • What ID did you give the “IP TV Host guy”? Did you give them the ID displayed in the top right corner of the screen (ID), or the MAC address (displayed in the bottom right corner of the screen? The one you should use, is at the top.

    I gave them my MAC address. Also when I enter my MAC address in app StbEmu (android smartphone) together with Portal link, then I can watch TV. But when I use the portal in MyTVOnline, then it won't connect. It's giving me the same error over and over again.