Official FW 1.4.71 - SW 7.9.1 for Z8 / Z Alpha / Z+ neo (28.07.2020)

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • The link you wrote send me to a "Access Denied" page (because of insufficient permissions).

    Can you solve the link please ?

    The DMR Thread is offline until some new tests and checks are done.

    The linked worked last night but seems to be restricted now, I was planning to do the Netflix download this morning. Hopefully it will be back up today.

    Sorry but no right to post here, is removed.

  • Netflix does work in hd, you just have to find the right version Netflix but you have to going find the hd version on github google is your friend the latest version will not do HD . I’ve tested a few version they play 1080 on Netflix, and on the Netflix addon kodi - qhd. The tests where done with test patterns found on Netflix. Disney plus is still not HD

  • I have a couple of questions. I read that you have obtained the official L1 DRM module, but that it requires a separate install. The ‘How To’ link posted above doesn’t work properly (not found) so I would like to have one that does.


    But even before that, I’m a little hesitant as to install this update, because I can’t seem to find out whether or not my TV supports HDCP 2.x. The TV is from 2014, and I really doubt it does. So, before even beginning to think of installing this latest firmware for the Z8, I’d like to know if I can force it to continue to use HDCP1.4 (which my TV does support. I don’t mind not being able to use the L1 DRM module that much, as I have plenty of other ways to access Netflix and other streaming services in HD (my TV doesn’t do 4K as the pannel simply doesn’t even know what that is yet, and my eyes are so woeful that they can’t discern the difference anyway.

  • L1 key deployment has been paused temporarily.


    Yes, your Z8 will fall back to HDCP1.4 as long as it is connected directly to the TV.


    Yes, you can still enjoy the benefits of L1 DRM at HDCP level 1.4

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • OK, thanks. That’s made things clear. Do we know when L1 deployment will resume? And, as a matter of fact, do we know why deployment has been paused in the first place?

  • bonjour, je ne peux pas lire le replay de plus de 8 jours. dois - je faire un ajustement?


    hello, I can not read the replay of more than 8 days. do I have to make an adjustment

  • After I made the update. I can't see any trailers anymore in vods.


    I have another z8 where I did not update. And the trailers is working and can be seen here.


    I use xc portal

    Same provider on my other box with old version and no problems

    Edited 2 times, last by soppdk ().

  • Hello, I have exactly the same problem like Lee. I can load the VOD's, if I select a VOD then I have no play button and cannot play the VOD. The external VOD player is deactivated. My provider has already checked his VOD offer - there is no error. I use the Formuler Z8.

    Unfortunately I did not make a backup before the update :(;(||.

    What can I do, will there be a new update soon?

    Thanks for reading:!:

  • Lee and tvpotato , i will contact you later trough pm since both have same issue. Please make meanwhile few screenshots from the issue for our discussion.Thx.