No subtitles on a subtitled channel when using cloud-based catch-up (LiveTV)

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

    • Model: Formuler Z8
    • Retail Box or Provider Box: Retail
    • Firmware version: August 26, 2020
    • MYTVOnline 1 / MYTVOnline 2 version: 2
    • Connection with provider: Stalker portal - ID/Mac registration
    • Box connected with: Tried both
    • What issue(s) are you having?
      When in EPG and going back time (after aired show) to watch a time-shifted cloud catch-up show, it appears the settings are VOD based and not LiveTV based (even though MOL2 is in LiveTV mode, just going back on EPG), I go into settings to get subtitles of that show/program/movie, to no avail. I know this channel has subtitles, as I watched the show live with subtitles, and when I go back to rewatch on same channel, for example, poof, no subtitles can be pulled. I know that they are there, since in my previous MAC-based device using same IPTV subscription, when I go back in time to watch a live show (yes, seems like a funny way to put it!), I get the same subtitles pulled from the server.
    • What was you expecting to happen?
      Expecting similar/same menu from LiveTV to pull subtitles
    • What happened instead?
      Cannot find subtitles on Opensubtitles, which is understanding, seeing as how the show just finished airing, nor able to pull subtitles from the cloud server of the provider
    • How can we reproduce the issue you are having?
      Using a MAC provider on a channel with subtitles and cloud catch-up, try to get subtitles (under settings)
    • What have you tried if anything to rectify the issue? Played around in the settings menu to no avail

    Is this a coding thing? Would I need to post this in feature request?