Black screen, again, from nowhere...

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • I must say that I'm going from pure delight to disappointment with this machine.

    Worked fine first week, then got the black screen and 10% loading.

    Well, maybe it's a stroke of bad luck, factory reset and everything went even worse. Factory reset once again, manual method this time. Was very happy to see it work.

    Now it's been running just fine for almost 2 weeks, but today....

    MOL2 stopped loading at 10% again. Restart, unplug, tried again. Went to 100% this time but black screen on every channel.

    Reinstalled MOL2, same thing...

    Am i supposed to factory reset this thing every 2 weeks? I mean, it's not the cheapest machine you can buy, I think there should be some kind of reliability...

    And before anyone asks:

    Yes, I have the latest everything, been running the latest hotfix and what not without problems since I had my last misery.

    No, it's not the provider. The portal works just fine on any other device and there hasn't been any downtime on their servers for a long time now...

    Tried to download iptv extreme and it works there aswell. On the z8 that is.

    If I sound frustrated its probably because I am. The only reason i got this was for the MOL2, and that's the only thing not working as it's supposed to....

    I guess i need to factory reset once again with all the hassle it brings....

  • Up and running again. Did a 2nd reinstall of MOL2, did everything from scratch. But thankfully no factory reset was needed.

    I'm not religious but I'll probably say a prayer each time I start it up from now on...

  • Zico

    Can you explain what you did for me i have for weeks now blackscreen with z8


    I messed with it for a long time so I'm not really sure what did the trick?

    Pulled the plug and let it sit for a while.

    Erased cache for mol2.

    Messed with the static/dhcp settings.

    Removed the portal, set up a new one.

    Uninstalled mol2, installed again.

    Nothing of the above worked, so i messed a bit more. I did the Uninstaller of mol2 and installed again, then it was OK... Have no idea why it worked the 2nd time and not the first? I'm not sure all my ethernet settings were the same at these 2 occasions so it could have been that.

    Now it's static, even going thru a raspberry pi4 vpn gateway in my network. I did try with a clean internet connection without vpn aswell with no result... I don't know, everything just works suddenly...

    What you should try:

    Does your portal work in other devices? Like mobile, directly from tv, pc?

    If it does, then something is failing on the z8. If not, it must be your portal/ provider/isp problem.

    But if it works on other devices, try to download another iptv- client on your z8, like smarters or extreme. Set them up with the same portal and try if they work.

    If they do, you know it's the app mol2 that has a problem. If they don't work either, you should assume that something in the z8 has a problem streaming this content to you. Test if YouTube and Netflix can stream.

    You may have to do a factory reset if that's the case and hope for the best...

    Edited once, last by Zico ().