Remote not communicating with set top box

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Hi just joined today as if just purchased a z8 formuler pro box started to set it up then all of a sudden remote failed to work. Tried everything switching on and off but no avail. So I used a mouse to reset the box so the box resets but it still won't communicate with the remote only the mouse. Can someone please advise me if it needs to go back thanks marbaker

  • hi v8rick

    Iv put new batteries in I have done everything switched on and off but still the remote is not communicating with the set top box. Only the wireless mouse works so I have reset everything started from scratch. Soon as it comes on to set up the remote does nothing but when I first opened the box to set up it worked fine i set up google play as soon as i came out of that set up 2 updates appeared and that is when the remote just stopped

  • hi v8rick

    Thanks for the reply yes I downloaded the app on my phone. And on the top of the remote app it says No STB so I'm sending it back today thanks again I just knew it wasn't the remote it has to be a software issue on the z8 box

    Thanks again