Z10SE Box Just Died

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Weehaggis You can hard reset the Device with a paperclip, first remove the power plug from the unit leaving the HDMI Cable attached and flip it over, to the right of the sticker there is a pinhole reset button with this button depressed "paperclip works to depress the button" , and HDMI still attached, plug the power back in untill the z10 se logo dissapears you will be prompted with a screen, remove the paperclip and choose wipe data/ factory reset on the system menu, once complete on the next system screen choose reboot system now... If your unsure you could always google "z10se hard reset"

  • I did a Hard Reset as instructed. I held the paperclip in for at least 2 or 3 minutes and nothing happened (I never got to see Logo.....just a blue screen saying "not connection")

  • You can Subbmit a ticket here


    New Ticket - Formuler Helpdesk


    They are generally really quick at responding, I might also suggest contacting your reseller prehaps you have a defective device? Needless to say, if you submit a ticket someone will get back to you... Right now they are celebrating the lunar new year and the office is closed. :frowning_face: but... Please do submit a ticket you can also upload a pic of the blue screen and the steps you took to resolve the issue

  • External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • The problem is ,I can't even get to the Logo. I hold the paper clip in for several minutes and all I see is a Blue Screen saying not connected.

  • The problem is ,I can't even get to the Logo. I hold the paper clip in for several minutes and all I see is a Blue Screen saying not connected.

    1. Please first connect with your reseller if Device is new resller might be of assistance


    2. If you have no assistance from reseller submit ticket to formuler, *note its currently a holiday and the office is closed while the Lunar New year is being cleabrated *, someone will get back to you ifyou Submit the request