S Turbo - Launcher doesn't response after Channel List upload

  • Hi,
    A few days ago I bought a new Formulerm S Turbo. It was working quite fine until yesterday when it crashed. I've uploaded a new channel list and after reboot the receiver does'n want to wake up. The front LCD displays "boot" and "load" for a few seconds and after that it becomes totally black. After some time on the TV there is an info "The laucher does not response". Does any one know how can I restore the system? Can I do this myself or it needs to be performed by the authorized service (it still under warranty)? What could caused that issue?

  • I've uploaded a new channel list and after reboot the receiver does'n want to wake up. The front LCD displays "boot" and "load" for a few seconds and after that it becomes totally black.


    When you press on Menu Button, can you see something? I think your channel list was not accepted and is now empty.

  • When I press the Menu Button it still doesn't respond. The screen remains black. Only when I press the Stand-by Button for a few seconds, a reboot menu appears.
    The channel list seems to be ok. I can open it in the ChEdit4Android and it looks ok. Probably something went wrong during an upload or reload.
    But assuming that something is wrong with the list is it normal that the Android crashed? Can I restore it somehow by maself?

    Einmal editiert, zuletzt von freddy76 ()

  • Nice to hear it works again :)


    Here the How to in English.


    S Series recovery:


    1. Format USB Stick with Fat32, download the file "Factory_reset_sw" and decompress.
    2. Copy the attached file (use the proper one for your STB, (S Mini) or (S Turbo)!) in to USB root (please without other files in root, copy only needed recovery file) and change the file name to "update.ird"
    3. Turn off your STB, unplug the cable and plug in your USB Stick.
    4. Plug in your Cable and receiver starts to reboot.
    *. Please click and click the Channel UP button continuously from start on RCU when rebooting.
    5. When you see "updt" on front screen, it does factory reset.

  • Did you use proper file (S Mini) for your Box? Tell us what happens when you do the procedure, see any Logo or error message? If this instruction doesn`t work then you need send your Box to repair.


    Important is the CH UP: After power ON, at same time clik continuously CH UP until Android update animation appear (Stop pressing CH UP button now), it will factory reset with Android Logo if it works.
    (Please retry. maybe you can click CH up button before plug in the power)
    If you see "Android logo" with ERROR message, the box cannot be reset with manual factory and needs to be repaired.

  • Hi Arion75,


    Do you have a rescue file for the S Turbo? The receiver is not bricked but is stuck in 'test mode'. we can disable the test mode in the software section however the firmware remains in test mode, even after reboot and factory restore.


    We tried the recovery launcher for the S Turbo but issue still remains.

  • Some problem i think... I sent a channel list via usb. Automatically it's restarted and then black screen. I put the "update.ird" file on formuler 4k s turbo and pressed channl up at power up. On display of decoder write "udate" - it's restart but - colored circle on screen tv but then.. black screen. Pressing other botton on remot control on screen tv is write "'l'app Launcher not risponde" closed app or attend but the 2 choices not work and black screen again.
    Help me please

    Einmal editiert, zuletzt von robertjust ()

  • Some problem i think... I sent a channel list via usb. Automatically it's restarted and then black screen. I put the "update.ird" file on formuler 4k s turbo and pressed channl up at power up. On display of decoder write "udate" - it's restart but - colored circle on screen tv but then.. black screen. Pressing other botton on remot control on screen tv is write "'l'app Launcher not risponde" closed app or attend but the 2 choices not work and black screen again.
    Help me please


    I have the same problem... I've uploaded a new channel list and the decoder doesn't want to wake up after reboot. I tried to recover the system using the "update.ird" (it helped last time) but this time it doesn't work. I have sill "laucher does not response" on my screen - same as robertjust. I used "*.nsvc" channel list file which was previously working without any issues. The Formuler's channel list becomes my nightmare... :S <X

    Einmal editiert, zuletzt von freddy76 ()

  • Hi Arion75,


    Thank you for the file and feedback. Unforgettably i cannot seem to get out of the test mode. The file did however allow me to perform a factory reset. but it takes be back to test mode.


    I may have to wait until the next test.release.

  • I used "*.nsvc" channel list file which was previously working without any issues. The Formuler's channel list becomes my nightmare... :S <X


    You need to make a list of channels and no problem. You have a problem because you're using someone else's channel list. Take your time and make it. Using the remote control the built-in [lexicon]editor[/lexicon] much faster is the list of channels. And save it on the drive for the reserve.

  • The list I uploaded is based on my list but grouped into favorites. It's my list which previously was working correcly. I don't understand why channel list creates so many problems and why it mostly ends with Android crash? And why I cannot restore the Android back?

  • "You need to make a list of channels and no problem. You have a problem because you're using someone else's channel list. Take your time and make it. Using the remote control the built-in [lexicon]editor[/lexicon] much faster is the list of channels. And save it on the drive for the reserve."


    But now that the decoder is blocked how can i do it?