Z10 SE Mac adress Wifi different from Box Mac Adress

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Hello everyone, i come to you because of a weird issue that i cannot resolve, i have a Z10 SE and have been using it via Ethernet without any issue. Now i had to move the box to a different room where i cannot use an ethernet connection so i connected it via Wifi. It connects ti the internet just fine but i notice it wouldn't connect to my portal via Mytvonline2. After some investigation i noticed that when connected via Wifi the box uses a complete different Mac adress then the one that you see on the label on the bottom of the box which is the one the box uses for ethernet and that is also used in mytvonline2. I read somewhere that this behaviour can occur on some Android boxes due to a privacy setting named Mac randomization but i cannot seem to find where to deactivate this so the box uses the same Mac adress for both Wifi and Ethernet.

    • New
    • Official Post

    If you use MAC/ID Stalker the box can only connect with provider with same MAC/ID you registered on Provider side and gave them, no matter if Ethernet or Wifi in use.

    Check your connection and ID, compare with the label.

  • If you use MAC/ID Stalker the box can only connect with provider with same MAC/ID you registered on Provider side and gave them, no matter if Ethernet or Wifi in use.

    Check your connection and ID, compare with the label.

    Hi Sam, thanks for the reply. Yes i am aware of that but this Mac adress problem is on the hardware side. Usually a box uses the same Mac adress for both Ethernet and Wifi but Formulers seem to act different. Just checked on my Z11 Pro Max and the same issue occurs, when logged to Wifi the Bix uses a completely different Mac Adress that he one used on Mytvonline3 and that's on the label at the bottom of the device, thus i cannot use a wifi connection to connect to my portal. On other Android devices that behaviour can be change and under Wifi settings in privacy menu you can force the box to use the device Mac on wifi, but there seems that you cannot change Wifi privacy settings on formuler devices

    • New
    • Official Post

    Just checked on my Z11 Pro Max and the same issue occurs, when logged to Wifi the Bix uses a completely different Mac Adress that he one used on Mytvonline3 and that's on the label at the bottom of the device, thus i cannot use a wifi connection to connect to my portal.

    Why you can not use it with Wifi if all others can do it? Disconnect Ethernet Cable first, log in Wifi and execute DHCP in IP Settings, maybe is that the issue.

    Wifi has his own MAC, that's right, Ethernet shows same MAC like from the BOX and label that you also use for registering on provider side and this one is important.

    The Box responds to provider and not the local Wifi.

    It is not unusual since a device can have several network adapters and therefore different MAC addresses.

    If you think that the wifi mac is the problem and you can not connect over Box Mac and use wifi, then change the Mac to something else.