Dead Z7+

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • My Z7+ froze while watching and did not respond to the remote in any way. I pulled the power in order to reboot. The light on the front momentarily went green and quickly turned red and faded down. I tried the recovery file as per instructions without success. I tried using the power supply from my mag 254 with the same results. Does anyone have anything else I can try? Or is it time to replace the box. It 's only about 6 months old.


    Thanks,


    hapy

  • My Z7+ froze while watching and did not respond to the remote in any way. I pulled the power in order to reboot. The light on the front momentarily went green and quickly turned red and faded down. I tried the recovery file as per instructions without success. I tried using the power supply from my mag 254 with the same results. Does anyone have anything else I can try? Or is it time to replace the box. It 's only about 6 months old.


    Thanks,


    hapy

    did you unplug any USB drives and WiFi adapter?

  • did you unplug any USB drives and WiFi adapter?

    Newfee,

    No, The box is hard wired. It had the same symptoms as if the box froze and did not respond to anything on the remote. So I pulled the power from the Z7+, waited a few seconds, and plugged it back in to reboot. It never started to reboot on the screen.

    hapy

  • I found the answer to my problem here at the Formuler Helpdesk:


    Check the steps below to resolve "No Signal" or "Invalid Signal" displayed on your TV:

    • Check the HDMI cable connection at the device and TV
    • Select the correct Input on the TV

    Check the supported resolutions on your TV.

    Your Formuler device might be set to an incompatible HDMI output mode.

    1. Turn ON the TV
    2. Pull the power from your Formuler device.
    3. Plug power back into the Formuler device.
    4. Wait at least 2 minutes for the box to boot up.
    5. Press the Resolution button on your Formuler remote
    6. Wait 5 seconds.
    7. Does the picture appear on the TV screen?
    8. If not, Press the Resolution button twice
    9. Wait 5 seconds
    10. Does the picture appear on the TV screen?
    11. If not, Press the Resolution button THREE times
    12. Repeat as neccessary.

    The key was #4 on the list. I was getting the "no signal" display on my tv.