4 GB file size limit for recording

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Code
    I would like to ask for help with following issue. While I am recording with my FORMULER S4 Turbo (bought last year, the newest firmware and software installed) on USB disk or Micro SD card the recording if larger than 4 gb is divided into separate files with size of each limited to 4 GB. I tried to combine these recordings to get for example a film to 1 file but there is some problem and the disruption when the recording stoppped in first file after reaching the limit of 4 GB and continuing in the following one is visible. USB and micro SD card are formatted with NTFS file system, I tried to format them through PC, Rufus and also FORMULER S4 internal format function. The problem still persists. Any hint or idea how to solve this issue are welcome, thank to everybody.
  • Missing information:

    • what tool or process did you use to combine the recording files?
    • when playing the separate files, is there any disruption at the beginning or end of the videos?

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • Code
    For splitting/joining video files I am using AVIDemux - in this case it opens the first file without problem but is unable to open/import second (third etc.) one. While playing the separated files by adding them to the playlist of BS player or VLC player it is visible that there is something wrong (the change between files - it does not look like pausing and than playing normal file - maybe the missing latest key frame is causing this as it is in the previous file only?). The problem looks like to exist at the beginning of the new file. Maybe it would be useful to know how Formuler splits these files whether if it just cuts the data and smoothly follows in new file so by simply joining them in PC through some simply joining program solves the problem (I did not try this yet)? Another issue is why is FORMULER cutting the file at all as it has a drive which supports larger than 4 GB files (fix of this issue in some further software update would be nice...).
  • Press the playlist button on the remote and play back the recording. Do you see any disruption in playback at the file boundaries?

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.

  • I made several tests according to your instruction/hints and the problem looks solved!


    1) If I open the recording through FORMULER file manager it plays only the opened part (file) of the recording. This caused my confusion as well as situation when I tried to play/edit these parts through several computer programs. If I use playlist button as you suggested the playback is OK, no disruption and the recording looks like one file.

    2) On my PC I tried to simply join the recording (those 4 GB parts) with some simple utility called "file joiner" and the recording is again in one file, no disruption detected, playback OK.


    So FORMULER just simply divides the recording into several files and joining them in PC is easy and the result is perfect.


    Many thanks for help from Czech Republic.

  • SAM

    Closed the thread.