VOD 4K - stop reading and return to menu

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Often when viewing 4K movies on VOD with MYTVONLINE there’s a message on screen “unable to show video”. Then the player return to VOD menu and I have to start all over.


    Any fix for this error?

  • Well it's claimed to be 4K and technically is but the only true 4K is 4K UHD blu-ray, high compression and low bitrates will make 4K streams overall picture quality less than that is found on UHD blu-ray.


    However have you tried another app, maybe perfect player or one from your provider? just to see out of curiosity if same happens with another app or just with mytvonline app. Does other vod content play? if yes i would find it odd the problem would be with the mytvonline app as whether it's hd, fhd, 4k it should not make any difference to the mytvonline app hence i think it maybe an issue with you're provider or connection.


    Without knowing much about your setup it sounds like to me either your internet connection is not fast enough, ie. netflix recommends a minimum of 25mbps and that's without using a vpn and other general factors that effects connection speed. You're router maybe not able to cope with the bandwidth or other device on your network using all the available bandwidth, try over ethernet if using WiFi.


    Also contact you're provider maybe a problem there end, tell them the error/problem you are getting and they maybe able to tell you why you are getting that error. I say this because the other day i had either the same or similar error (cannot remember) and it was a server problem with provider not being able to load some videos. Then i had another issue where vpn was not enabled on vod content so had to contact provider to enable as prior to that video would not load, just cannot remember for the life of me if it was exact same error as yours or similar.


    One last point, they must be a very good iptv provider with stonking servers if they can stream 4k content to users without it effecting there servers. ie. server overload and the fact streaming of live tv etc as well. Many providers servers struggle with just streaming FHD hence i find good ones tend to provide vod and on demand in 720p and some 1080p to stop there servers struggling so for them to be streaming 4K it is rather suprising as servers don't come cheap to rent. Please do not take this as criticism as it is not, just a point i feel is worth noting.


    Or i could be totally wrong and maybe a bug, reply back with more information as without it, it's difficult to determine.


    EDIT: Sorry made a few edits so you will need to read it again.

  • Just a quick update.


    The other day i do remember this happening, when playing vod and when rewinding/fast forwarding on occasions for no reason the video would stop and return to menu. So this is likely a bug but i get a feeling for some reason the error being described is maybe a seperate issue although i could be wrong.


    Also not sure if this is provider end or not but when playing VOD content sometimes the total time (time until video finishes) will show crazy amount of hours other times it shows the correct total time.

  • 25 mbs constantly is must have for 4k. In next update will one critical vod playback bug be fixed, could be this one.
    Rpmms please wait for next update and check this issue again.