Since update to 1.6.54. nothing works, receiver doesn´t start - Formuler S Turbo

We asking all new users to read the articles below, before creating their first posting or thread.

  • 4. Instruction Articles

    • Please note, in this forum are only English threads and postings allowed, without any exception!

      Please follow the forum rules, thank you for your understanding.

  • Hello guys, yesterday i was very pleased to see that there is the new Update to Version 1.6.54.


    But now my S Turbo has a massive Problem, it doesnt start anymore, if i turn on the receiver i can see the bootlogo (the Rings) but after this it switches to a black screen, from time to time it shows "App Launcher doesnt work - close or wait" - no matter if press "close app" or "wait", nothing works.

    Frontdisplay shows nothing, completely black.


    I can´t find a workaround for my problem by searching the forum and the internet.


    Beforehand, I have completed the update process. The device was nearly 2 hours without any touch while the update was running.


    I´m 30 Years young and usually i know how handle devices like this.


    To fix the Problem i tried following things:

    - disconnectet from AC for 30 min - no effect

    - again disconnected for 30 min, all other cables (HDD, WLAN) except HDMI plugged of, connectet AC again, no effect

    - tried to close open apps by pressing menu long time - no open apps - no effect

    - above things i tried again and again, no effect, nothing helps!

    - i ve waited 2 hours with turned on device - black screen stays

    - at least i tried to find the firmware on the internet to start the update manually by pressing the power button on the device while connecting AC but i cant find any firmware online for the device


    My big Problem is i cant do anything, i cant go to menu and start a factory reset beacause the box doenst start and stucks bevor i can do anything, with every command on the remote the box says "App Launcher doesnt work"


    What now? The box is now 1/2 year old and since this update it is completly unusable!!


    Please, please help! What can i do? Is there a possibility to go to a secret menu while booting where i can do a factory reset? ;(


    Thank you so much, kind regards!!

  • Hi,

    first unplug all devices from box (usb, sd card etc. ) and try to factory reset with one of this two methods.


    1. Factory Reset from firmware 1.2.71 (works also with S Series)

    or

    2. Official Formuler S - Series Factory Reset Tool and how to

  • Thank you so much SAM! 8)

    You made my day! Now i know how to deal with problems like this, your first suggestion worked great, settings backup installed, the s turbo runs :thumbup: now. 15 Minutes of Work.


    :thumbup::thumbup::thumbup::thumbup::thumbup:

  • SAM

    Added the Label Solved
  • I have the same problem of Kaschpal 84 my formuler s turbo don't work. I see on video app launcher don't answer help or wait

    I try with the tool on root USB but nothing please can you tell me if there is another system to repair my formuler s turbo?

    thank you in advance for your help

    Best regards

  • This are the two ways how to factory reset if you can not reach home menu. I know it is little bit tricky and need right timing with RCU but try few times more until the FR works.

  • SAM

    Closed the thread.