Location settings

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • I recently tried to install an app for DirectTV Now from the Google play store. The app installed ok but once I launched it, it was asking to enable location services. However I can't find that anywhere in the settings. Is it possible to manually enable that? This app apparently needs it to find your location to get your TV guide and local channels. I'd really like to try to continue to use just one device for my needs but I'm finding I need a couple because of issues like this. Let me know if this is something I can take care of or if it's not an option.


    Thanks in advance

  • Hi,


    From home screen.


    1) Select cog icon (settings icon)
    2) Select Android
    3) Now if you logged into Google (use fake account if u like) scroll down til you see Google and select it
    4) Now scroll down til you see Location.


    Can't remember if i had to login to see the Google menu above, however another way


    1) Select cog icon (settings icon)
    2) Select Android
    3) Top right hand corner select the magnifying glass (search), type in Location and it should come up.


    Try second method first as you should not have to login to a google account to enable location services i'm sure of it.


    Second method can be used for android settings that have been removed from the settings menu, anytime you cannot find something use the search feature as described :)


    Also i keep mine off or use a app like fake gps from google play store so you can fake you're gps coordinates :P

  • Thanks for the help. I tried the first 4 steps but when I selected Location it went to a white screen and then gave me an error to end the app and I tried the other steps but just decided to try the fake gps. It seemed to work however the app doesn't play well with the Formuler. It got pretty aggravating so I guess it's not an app I can use on the Formuler. It works great on the Fire TV so I guess if I decide to keep playing with it I have to keep both and switch between the devices.

  • Sorry should have mentioned i never tried the app on the formuler take a look at google play store i think there are others you could possibly try.


    In regards to the white screen and the error, what did the error say? unfortunately it seems everyone is getting a high amount of crashes, freezes, app not responding, infact it's beyond a joke. the IPTVLauncher is a nightmare and crashes far to often and needs looking at with priority, i can't say anything more as it worked for me, maybe try logging into a google account on the formuler first then try location settings as allot of it is linked to google account and maybe you need to login first. Other than that a factory reset and software reset, although this is not a solution every time something happens which at the moment all people are told is to reset boxes and i for one will not being reseting and redoing entire box every time is plays up.

  • It sits at the blank white screen for a while, at least a min or two, then since nothing is happening I hit the OK or up and down arrows then shortly after that it comes up with the message "Google Play services isn't responding" then a Close app, Wait, or Send Feedback are my only options. I Close it then it goes back to the blank white screen and does it all over again. The only way out is to hit the Home button.


    I also tried the search and it did take me to the Location Services but it was already on and I was kind of stuck at that point. The app I was trying to use didn't seem to pick up on the location services being on already even after I accepted it to use my location. Oh well....the fake gps worked but like I said the app didn't work well on the formuler, so I'll be using that app on the fire tv.

  • well least you found an app for use on another device :)


    ok only other thing i can think of if location services is on is the following:


    From home screen -> cog icon -> Android -> Apps -> locate the app in question and select it, then select permissions and ensure location permission is enabled to allow app to access location. If that doesn't work i am assuming the google play services is causing the issue, ie. app tries to use location but google play services is crashing causing app to be unable to use the location service. But try the app permission suggestion above, also maybe logging into a google account on the formuler may work sounds odd i know.

  • Update:


    possible bug:


    OP has not replied but yesterday i did a software reset then factory reset, no running apps or anything totally fresh factory reset.


    I can confirm that when going to Android -> Google -> Location, it causes a white screen, apps becomes unresponsive. Only way to exit is go to home screen, Only way to turn Location on/off is to search location as mentioned in my previous post above.

  • Im just wondering if theres a bug in this... why is it turning on location issue so hard.. now in android setting this seems to crash when you hit location ..ive read these post and see now here to "search" for location .Need a real guide how to have this fix

  • Right, i was able to reproduce this issue. I opened internal ticket for this, should be fixed in next fw.

  • This is a known issue.


    Engineers will work on a patch for this after the late-August/September release.


    Thanks for your patience.

    Unsolicited PMs for support will be ignored.

    Duplicate support requests to the forums and helpdesk will be ignored.