>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Hi,


    I just received my Formuler Z7+ and I've noticed the wifi is just too slow. The router is just a couple of meters away and the connection quality is excellent but channels refuse to play without buffering. I tested the speed using the speedtest app and it returned speeds of between 1 to 2.5 Mbps. Doing the same test using my phone left on of the Formuler 7Z+ to be at the same distance and connected to the same wifi the speeds were up to 100 Mbps. I tried connecting it to the router with an ethernet cable and that way it worked but I cannot keep that way.

    Is this the normal speed expected from the receiver?


    Thanks.

  • SweetBrick4 No, not really. While searching on internet, I found this forum and I instinctively thought this was their support. I don't know why. I'll try the static ip option (I don't really understand what that could possibly change) and then I'll create a ticket in their ticket system.

  • ive just posted a similar thread , awful wifi .


    "Make ip static on z7+. Most of time will solve the issues" - how do i do this please ?

  • I actually tried the static ip solution and... I don't know whether it work. First time I tried, I reboot the device but I still didn't have good speed. I disconnected it and went to bed and the next day I just plugged it and the wifi worked. So I don't what to make of it but for now it's working and let's hope it keeps it that way.

    robLFC , you have to go into Settings -> Wi fi -> long press your wifi connection -> Modify options (or something similar) -> Advance options -> Scroll down (the option to change from DHCP to static is not visible until you scroll) -> Change from DHCP to static -> Add your config.

    Normally this is:

    Gateway: 192.168.1.1 (your router internal IP)

    DNS 1: 192.168.1.1 (basically your router)

    DNS 2: 192.168.1.1

    IP: 192.168.1.XXX (change XXX for any value between 2 and 254. I added 125 to avoid clashing with any other device I may connect to my router)