Z8 MYTVOnline 2 does not load channels but can access VOD section of Sub - All live channels shows Black screen only

>> Important Information <<

If users still ignore our forum rules and post again portal`s by name and url`s, the thread will be closed, postings deleted and user/s banned.
This is not a support forum for provider/portal related issues! Pleas follow the forum rules.

Thank you for your understanding.
  • Hello,


    I am having strange issue with Z8.


    I have one sub which i put into Portal section of Z8 MyTVOnline 2 app. It needs username and password with portal so i put the username and password in it. Once i click connect, It connects to Sub successfully.

    BUT MYTVOnline 2 does not load any channels. I can see the channel list, groups, EPG everything. But the picture is BLACK screen. No live channels loads.

    But if i go under VOD section on same sub, I can see everything and i can play videos successfully. No issue at all. I can access TV Series section to successful.

    Just Live channels Does not load and shows BLACK color screen.


    I have downloaded this Sub's APK on Z8 and in APK, i can see live channels successfully. No issue at all.

    Just MyTVOnline 2 does not show me any live channels.


    So can someone please help and let me know if there is any fix or if there is anything i can do to fix this. I know this is not sub issue because it works fine on computer and on APK. Just MyTVOnline 2 does not work.


    Any help would be appreciated.


    Thank you.

  • i have the same problem with a provider and with vpn it work.

    With my another provider everything works fine without vpn.


    I dont know Why...

  • i have the same problem with a provider and with vpn it work.

    With my another provider everything works fine without vpn.


    I dont know Why...

    I don't even use VPN. With this provider, If i use Provider APK, it works fine. If i try to use MYTVOnline 2, then it does not work.

    So it's a issue with MYTOn 2.

  • I don't even use VPN. With this provider, If i use Provider APK, it works fine. If i try to use MYTVOnline 2, then it does not work.

    So it's a issue with MYTOn 2.

    I dont know if mol2 is the problem because with mol 1 on formuler z7+ i have the same problem too ...

  • I'd be willing to bet that will be a symptom of blocking and censorship of you and/or your provider undertaken by your ISP

    I thought about that too but others who have the same ISP as me and the same provider do not have the problem

  • I thought about that too but others who have the same ISP as me and the same provider do not have the problem

    With all due respect it is my personal belief that to say so is to understate the case and/or possibilities as there are a great many variables to be taken into consideration, and particularly so when comparing even the same ISP's service in different locations.

    OK, so MTVOL2 might not be perfect just yet and as we know is under continuing development, but symptoms like that do tend to suggest an issue with an ISP or something to do with activity (possibly outside of your control) within an ISP's upstream network. These things tend to become very apparent when there are particular sporting events underway (and I am sure that today will have had it's share of those).


    The forum rules here prohibit us from discussing details in public (and rightly so IMHO), but if I was to say that there are a few basic rules that I learned many years ago about networking that have served me very well over the years and continue to serve me well.


    1. Never ever ever use an appliance (ie router or whatever) supplied by an ISP. Instead use an appliance that you own and control using Free or open Source software that is able to be regularly curated and updated by you and you alone and no one else.


    2. Never ever ever use an an ISP's DNS service/server/nameserver. Instead use an independent one. Today I would recommend Cloudflare's 1.1.1.1 but be prepared to review and change on a regular basis. A viable alternative or secondary supplement for many today would be to use OpenNIC.


    3. Take 'ownership' and control of as much of your network as you possibly can. The internet of today is a place where the big corporates effectively act as judge jury and executioner and in effect write their own 'laws' with impunity, so if we as the little-man at the client end of things are to stand half a chance of getting what we want, then we must be prepared to roll-up our sleeves and put in some time and effort.


    As a final comment, in some parts of the world a country's mainstream 'big' ISP's get mandated by their courts and legal systems to undertake pro-active blocking and censorship activities. My advice would be to get to know and understand who those companies are in your country, and wherever possible avoid using their services, and instead use a smaller independent 'boutique' type operator who is not typically bound by such undertakings. Such research and understanding takes time to learn and understand but does often pay massive dividends, and sometimes can even save you money as well.

    Using a VPN service is also a good option. Commercial VPN services vary wildly in both price and performance, so I tend to simply 'roll-my-own' as and when I feel the need for one - - - they are very easy and quick to knock-up on a VPS somewhere and are oftentimes cheaper than a commercially available service.

  • I'd be willing to bet that will be a symptom of blocking and censorship of you and/or your provider undertaken by your ISP

    I do not believe that my issue is related to ISP Because I can access my provider portal on my Laptop, my phone and Provider APK which all are connected to same Provider portal. And everything works fine. So if ISP is blocking anything then my provider portal should be blocked on all my devices as all devices are connected to same internet. So ISP is out of the question here.


    I do not even use ISP dns on my whole network. i use the same 1.1.1.1


    The provider portal does not work just inside the MyTVOnline 2 app. It works on Formuler Z8 in Provider APK. So there is something to do with MyTVOnline 2 App here.

  • MOL/MOL2 has an issue with creating too many connections to the server, especially with XC portals. Some providers will ban the ip and/or account thinking it is a flood attack. I know of at least one provider that has now been telling clients not to use MOL/MOL2 of they will be perm banned so they may possibly be blocking the app as well. It's a known issue but still seems persistent through the current betas.

  • MOL/MOL2 has an issue with creating too many connections to the server, especially with XC portals. Some providers will ban the ip and/or account thinking it is a flood attack. I know of at least one provider that has now been telling clients not to use MOL/MOL2 of they will be perm banned so they may possibly be blocking the app as well. It's a known issue but still seems persistent through the current betas.

    Yep, and it happens with both portals that require both a username/pass and ones that are MAC locked. For now I have to use another app to get around that, or have to contact my provider every couple of hours to unblock my IP.

  • MOL/MOL2 has an issue with creating too many connections to the server, especially with XC portals. Some providers will ban the ip and/or account thinking it is a flood attack. I know of at least one provider that has now been telling clients not to use MOL/MOL2 of they will be perm banned so they may possibly be blocking the app as well. It's a known issue but still seems persistent through the current betas.

    Well informed :thumbup: But this problem exist at moment only on MOL2 and the main reason for the bans is: requesting too much data quickly from the server. Have to say it depends also from Provider and security settings, high settings= ban, lower settings= all fine. Here to find the golden middle is hard, on one side happy users and fast experience and on other slower connections to provider. Devs. working on this issue and i think the fix will come with the official update this month. Mol had in past once same problem and it was fixed quickly.

  • Well informed :thumbup: But this problem exist at moment only on MOL2 and the main reason for the bans is: requesting too much data quickly from the server. Have to say it depends also from Provider and security settings, high settings= ban, lower settings= all fine. Here to find the golden middle is hard, on one side happy users and fast experience and on other slower connections to provider. Devs. working on this issue and i think the fix will come with the official update this month. Mol had in past once same problem and it was fixed quickly.

    I had the same problem on mol 1 so it's not that about mol 2

  • What exactly on MOL1, missing channels or ban?

    MYTVOnline 2 and mol 1 does not load any channels. I can see the channel list, groups, EPG everything. But the picture is BLACK screen. No live channels loads.

    Same with vod

    Just Live channels Does not load and shows BLACK color screen.


    i have the problem with a provider and with vpn it work. I dont ban with this.


    With my another provider everything works fine without vpn.

  • Well informed :thumbup: But this problem exist at moment only on MOL2 and the main reason for the bans is: requesting too much data quickly from the server. Have to say it depends also from Provider and security settings, high settings= ban, lower settings= all fine. Here to find the golden middle is hard, on one side happy users and fast experience and on other slower connections to provider. Devs. working on this issue and i think the fix will come with the official update this month. Mol had in past once same problem and it was fixed quickly.

    Unfortunately, the problem does still exist in mol. It's not quite as prevalent as before because of devs work and providers have been lowering their flood protection to somewhat accommodate but some still ban and refuse to lower their security for obvious reasons. Oddly enough, using a VPN is a work around for the issue and will stop the auto bans. I agree, middle ground is hard to find but other apps and devices don't have the issue so it's certainly possible. :)

  • boul05

    Please open support ticket and provide detailed information, so the devs can check this issue.


    Islander

    I agree, there must be found good solution and i believe they will.

  • Having a similar problem with my box, I'll be flicking through the channels, all working fine, all of a sudden I'll get a channel which is just a black screen, I'll then go back to a channel which was working before, or any other channel and they'll all just be black screens with no connection on the 3 bars.


    Usually what I'll have to do is connect to another subscription, watch that for 10 mins then connect to original one again.


    Now I only have one subscription so what I have to do now is exit the app wait again for a 10 minutes or so and reconnect.

  • Fraz - that’s what’s been happening to me after my previous post - I see the black screen and 0/3 bars after a while either after swapping some channels or after watching a channel for a while and suddenly it stops.


    No idea what causes the first problem (even though it might be flood protection) but the second is caused by the box opening two or more connections to the server and flood protection kicking in.


    Can’t wait for this to be fixed, since it happens in MyTVonline2 and doesn’t happen in Iptvsmarters for live tv. Now I’m stuck with a rather inferior app just so I don’t have as many problems with the live channels

  • Fraz - that’s what’s been happening to me after my previous post - I see the black screen and 0/3 bars after a while either after swapping some channels or after watching a channel for a while and suddenly it stops.


    No idea what causes the first problem (even though it might be flood protection) but the second is caused by the box opening two or more connections to the server and flood protection kicking in.


    Can’t wait for this to be fixed, since it happens in MyTVonline2 and doesn’t happen in Iptvsmarters for live tv. Now I’m stuck with a rather inferior app just so I don’t have as many problems with the live channels

    Yeah it's very annoying. Just moved from a mag box to the Z8, when it works it's aawesome so really liking forward to a fix for this

  • Yeah it's very annoying. Just moved from a mag box to the Z8, when it works it's aawesome so really liking forward to a fix for this

    Same, moved from mag to Z8, but this is so far the only real gripe I have with the box - mytvonline2 is great when it works, but with these lockouts it’s my choice for vod but definitely not for live channels